r/techsupport May 17 '22

Internet but no internet! Solved

Hey all, basically I have internet in my browser (opera) but no internet for apps or even according to settings. I bought an external adapter, reinstalled drivers, tried changing DNS and all that fun stuff but still nothing. I can watch YouTube no issues, but as soon as I try to load MS word to upload a document to the cloud it says no internet available. Any ideas?

Edit: Thank you all for helping with my really strange dilemma! I have completely reset and reinstalled windows and it seems to have worked! Don't wanna be doing that every time it fails though! Thanks again!

18 Upvotes

6

u/intenzemotion May 17 '22

That is some weird issue. In cmd, try execute these commands:

  • netsh winsock reset
  • ipconfig /flushdns
  • ipconfig /registerdns
  • ipconfig /release
  • ipconfig /renew

These are my personal go-to fix. You might have to restart your PC after executing the commands.

Edit: Formatting

3

u/jalexx07 May 17 '22

You can try either of the following

  1. Search “inetcpl.cpl” on windows search and click on the control panel item. Click on the connections tab, then click on “LAN settings”. Make sure “automatically detect settings” is checked and all other options are unchecked

  2. Search “network connections” and click on “view network connections”. Right click on either the Ethernet or wifi adapter you’re connected to and click “properties”. Then double click on “internet protocol version 4” and make sure both settings are set to automatic in both the general and alternate configuration tabs. Then hit okay and do the same for “internet protocol version 6”

1

u/Sporktical May 17 '22

Yeah I've done both of those, several times after restarts and still nothing. I've also had a fiddle with drivers, adapters, and all the other CMD prompts I can think of... but thanks anyway!

1

u/iamthepita May 17 '22

Uninstall MS and reinstall

2

u/Sporktical May 17 '22

damn, the whole thing? That's going to take forever! Okay I'll give it a go, thanks!

3

u/iamthepita May 17 '22

Yeah, it sounds like any changes on your network isn’t reflected in the software configuration of MS, Easier to delete and reinstall than trying to fix it

2

u/Sporktical May 17 '22

Okay, what about all the other apps? I've got others that won't connect (like Spotify). I'm honestly thinking I might just completely reset my whole computer.

1

u/iamthepita May 17 '22

Are you using VPN?

2

u/Sporktical May 17 '22

No, I do have one, and it will actually connect no problems, but it's not on usually. Turning it on doesn't fix or change anything though, except maybe my internet on the browser getting the tiniest bit slower.

1

u/iamthepita May 17 '22

I wonder if you configured all of your apps with VPN back then and it’s been running off the old configuration

2

u/Sporktical May 17 '22

Nah VPN is a pretty recent addition (only about 3 months ago) and everything was installed and used before that.

1

u/iamthepita May 17 '22

Hmm. You got me stumped. I have to figure it out by actually being hands on (my brain is weird) and I’m not asking to do that… I’m just stumped at the moment

2

u/Sporktical May 17 '22

Yeah me too. I went into a tech store here in town and they said 'never heard of that before, good luck!' so I've been watching tutorials on YouTube about resetting, uninstalling, reconnecting, and all that... on the device with no internet. It's weird. It's an old laptop though, I'd say 6-7 years old... Maybe it's time for a new one.

→ More replies

2

u/alkoka May 17 '22

I would still check the VPN app if the KillSwitch is turned on. That usually can cause such issues, happened with me too. You don’t even see it outside the app itself.

1

u/Gamer7928 May 17 '22

I'm just wondering if your Firewall could possibly be blocking Microsoft Word and other applications from internet access? It's certainly worthwhile checking into. If this is indeed the case, then it's quite possible your Firewall is misconfigured.

2

u/Sporktical May 17 '22

I've had a look at that, my firewall from avast is won't show me anything because it just says 'connect to internet to view firewall options' and the inbuilt one is saying no problems and I've whitelisted all apps I know have problems, still nothing

1

u/Gamer7928 May 17 '22

So Avast! Firewall won't show you a list of allowed and blocked applications?

2

u/Sporktical May 17 '22

not without internet, for some reason. I'm going to switch away from Avast! when I reset my laptop anyway but I'm not sure why I wouldn't be able to see the settings.

1

u/Gamer7928 May 17 '22

First time I heard of any Firewall software intentionally hiding a list of blocked and unblocked applications. Before resetting your laptop, try disabling Avast! Firewall first; want to see if that fixes the problem.

2

u/Sporktical May 17 '22

Yeah, I've actually just disabled all of Avast! to see if it'll make a difference, but nothing there either. I think the whole laptop just needs a fresh start. I tried hotspotting from my phone so I could view the firewall but I had the same problems with that network too so... oh well. Thanks!

1

u/Gamer7928 May 17 '22

Wait, your phone also has spotty internet access as well?

2

u/Sporktical May 17 '22

oh, no. I meant my laptop would act the same with my mobile hotspot, but I've tried the hotspot on my mum's laptop and it's perfectly fine, so it's a problem with my laptop connecting to any network, I think.

2

u/Gamer7928 May 17 '22

Or rather your applications outside your internet browser, which I too have never even heard of happening. Could it be Opera itself causing all other applications being blocked from internet access? Opera does have a built-in VPN so perhaps that has something to do with your problems.

2

u/Sporktical May 17 '22

yeah me either, I have literally no idea how it happened, but hopefully a reset will fix it. I've asked a couple of other IT people I know IRL and one said the only fix will be a hard reset, the other said 'maybe you could just cancel your internet plan and live in the loophole haha' so that's all I've got from people who have actually seen the laptop in person.

→ More replies

1

u/Nelman79 May 17 '22

Try restoring you PC to a previous point. It might solve your problem all together man!

1

u/Sporktical May 17 '22

yep, in the process of doing that! it's been at 1% for about 45 minutes now! Slightly concerned the laptop is gone for good...

1

u/ShyftOnReddit May 17 '22

its not gone dw. if all somehow fails resetting it, which likely will not happen, you could still install windows again anyway

1

u/Sporktical May 17 '22

yep, I've reset it, and after a grueling few hours, all has fixed itself, thanks!

1

u/dug99 May 17 '22

Are you with Mate? Asking for a mate. Jokes aside... do you have another user profile you can log in with? If not, create a new one and try it.

2

u/Sporktical May 17 '22

I did in fact try that as well, no win, but it's all good now, after a fresh windows reinstall, it's sorted!

1

u/jcwrks May 17 '22

Edit: Thank you all for helping with my really strange dilemma! I have completely reset and reinstalled windows and it seems to have worked! Don't wanna be doing that every time it fails though! Thanks again!

Reinstall all of your apps and customizations. Get an external hard drive and create a backup image. I would recommend updating it weekly since you can let it run while you are sleeping. Next time you have a major issue you can restore from the image.